蔚蓝触点 Azuretouch

Azuretouch
Touch your future

如何使用工具自动生成 requirements.txt

在 Flask 的开发过程中,经常会安装需要的依赖包,有时候懒,自己也不会记录下来,时间一长就忘记了安装过什么。项目发布的时候,就不知道要在生产环境上装哪些依赖包了。

其实解决方法很简单。pip 下有个工具 pipreqs,可以获取指定项目中所有用到的依赖包,然后生成 requirements.txt。

直接上代码:

#安装 pipreqs
[[email protected] ~]# pip install pipreqs
#指定项目路径,导出依赖包列表
[[email protected] ~]# pipreqs ./ 当前目录
INFO: Successfully saved requirements file in ./requirements.txt

在目录中打开 requirements.txt,可以看到安装包及版本号都列在里面了。在新环境中执行一下命令,便可一键安装。

[[email protected] ~]# pip install -r requirements.txt 

另外,pip 还可以获得系统中所有安装过的依赖包:

pip3 freeze 
pip3 freeze > requirements.txt
未经允许不得转载:蔚蓝触点 Azuretouch » 如何使用工具自动生成 requirements.txt

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址